biVector forum

GAViewer for Mac is Broken

I was reading the PGA4CS writeup by @LeoDorst and wanting to use the examples. I had formerly run GAViewer on my Mac when I bought his book, but after the latest OS upgrade (Big Sur 11.3.1) it runs, but only displays a grey window without other features. I am not sophisticated enough to try to compile it myself. Can anyone fix this? Forgive me if this is the wrong place to post this. I am new to the forum.

Indeed it looks like the iOS version of GAviewer is finally biting the dust after 15 years.
We looked at it, but we have no resources to keep it alive indefinitely. There are more advanced platforms for GA available now. Some of them could perhaps support a GAViewer emulator, and that would be de way to go.

This is too bad. From your youtube videos it looked like GAviewer was a nice complement to the book, and I was looking forward to doing the programming exercises.

I tried to compile it on macOS 11.2 but failed there as well. Here’s what I attempted, if someone wants to try going on:

brew install fltk antlr@2 libglu
export LDFLAGS="-L/usr/local/opt/antlr@2/lib"
export CPPFLAGS="-I/usr/local/opt/antlr@2/include"
./configure
make

Make fails with a large number of ‘Undefined symbols for architecture x86_64’, so either antlr@2 isn’t 64-bit compatible or else it’s not getting linked properly.

I wonder if gaviewer might get some open source attention if there was a github project (and someone willing to merge PRs).

I built a docker image to run gaviewer. It should run on any OS.

Information on launching the image is on github. You can also pull the docker image directly from docker hub: docker pull blivens/gaviewer.

One issue I’m still running into is that I can’t interact with the figures. I can rotate in 3D, but dragging the points and lines doesn’t do anything. It’s unclear to me whether this is an issue with gaviewer or with the way I run and interact with it. If anyone can try it out and provide feedback that would be nice.

1 Like

I recall (this is from several years ago) that I had to buy a 3-button mouse to interact with it.
https://smile.amazon.com/gp/product/B005EJH6RW/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1